请选择 进入手机版 | 继续访问电脑版
查看: 2888|回复: 1

CVE-2021-22555: Linux Netfilter本地权限提升漏洞

[复制链接]
匿名
匿名  发表于 2021-7-16 17:27:27 |阅读模式
本帖最后由 匿名 于 2021-7-16 17:29 编辑

报告编号:B6-2021-071601
报告来源:360CERT
报告作者:360CERT
更新日期:2021-07-16

漏洞简述


2021年07月16日,360CERT监测发现国外安全研究员@theflow公开了CVE-2021-22555 Linux Netfilter提权漏洞的分析报告,漏洞编号为CVE-2021-22555,漏洞等级:高危,漏洞评分:7.8。
Linux Netfilter 模块是内核中用于管理网络数据包的一个软件框架,被人熟知的 iptables,nftables等工具均是基于 Netfilter 开发的。该漏洞利用 Netfilter 中 memcopy,memset函数的使用过程中的逻辑不当实现权限提升。
该漏洞在kCTF中被用于攻击kubernetes pod容器实现虚拟化逃逸。
对此,360CERT建议广大用户及时将Linux Kernel升级到最新版本。与此同时,请做好资产自查以及预防工作,以免遭受黑客攻击。

风险等级

360CERT对该漏洞的评定结果如下
评定方式等级
威胁等级高危
影响面广泛
攻击者价值
利用难度
360CERT评分7.8

漏洞详情


CVE-2021-22555: linux kernel-netfilter 特权提升漏洞
CVE: CVE-2021-22555
组件: kernel-netfilter
漏洞类型: 特权提升
影响: 权限提升;服务器接管
简述: Linux 内核模块Netfilter中存在一处权限提升漏洞,在在64 位系统上为 32 位进程处理 setsockopt IPT_SO_SET_REPLACE(或 IP6T_SO_SET_REPLACE)时,如果内核选项CONFIG_USER_NS 、CONFIG_NET_NS被开启,则攻击者可以通过该漏洞实现权限提升,以及从docker、k8s容器中实施容器逃逸。

影响版本


以下版本为hash内容的是 Linux Kernel 完成修复的 git commit
组件影响版本安全版本
Linux:kernel-netfilter<b29c457a6511435960115c0f548c4360d5f4801db29c457a6511435960115c0f548c4360d5f4801d
debain:stretch4.9.228-14.9.272-1
debain:buster4.19.171-24.19.194-1
Linux:Kernel>=2.6.195.12,5.10.31, 5.4.113, 4.19.188, 4.14.231, 4.9.267, 4.4.267

修复建议


通用修补建议
根据影响版本中的信息,排查并升级到安全版本
临时修补建议
根据 RedHat 的建议,用户可以实施以下操作通过禁用非特权用户执行CLONE_NEWUSER、CLONE_NEWNET,以缓解该漏洞带来的影响
echo 0 > /proc/sys/user/max_user_namespaces

产品侧解决方案
若想了解更多产品信息或有相关业务需求,可移步至http://360.net

回复

使用道具 举报

  • TA的每日心情

    2021-7-26 14:51
  • 签到天数: 2 天

    [LV.1]初来乍到

    发表于 2021-7-25 09:18:08 | 显示全部楼层
    4b4480d307d84a0146e356e1262eb3f9
    回复 支持 反对

    使用道具 举报

    您需要登录后才可以回帖 登录 | 注册

    本版积分规则

    快速回复 返回顶部 返回列表